請選擇 進入手機版 | 繼續訪問電腦版

NoName Team 電腦資訊討論區

 找回密碼
 我要註冊
搜索
樓主: 呆呆烈

[分享] Win7PE by nu888 (修改版)

[複製鏈接]
發表於 2016-11-12 18:21:40 | 顯示全部樓層
感謝分享
發表於 2016-11-15 10:59:47 | 顯示全部樓層
WI7PE真的應該是最好用的 不像是目前WIN10 很多東西用起來都怪怪的或者程式不支援
謝謝大大
發表於 2016-11-16 09:48:01 | 顯示全部樓層
本帖最後由 fd3233 於 2017-8-21 10:31 編輯

等會修改完成後上傳
我就不重新開新貼了 此版本只此一版不再做後續更新與精簡

W7PE_NF20 FIX_Extend_USB3_20161116.iso

停止分享

已經修改的項目
1.8PEtools 改名成 7PEtools
2.新增顯卡、網卡、無線網卡 驅動7PEDrivers.WIM  (188MB)
3.添加Acronis True Image 2017 5534X 與共用 xpe extra3 第七版有更新到最新的軟體
4.修改桌布為win7 預設
5.Potplayer 1.6 、7-zip、Firefox 為wang_966提供版本

其他測試項目: (沒有整合)
嘗試添加 IE11 失敗 (測試dism方式添加跟直接boot.wim資料夾添加皆失敗)
還無法使用 Aero 主題功能
嘗試添加 intel usb 3.0 驅動 不過在我的主機板不相容


已知問題
1.在實體電腦測試  載入顯卡驅動後會有一個常框框不知該如何去除

2.使用Rufus 製作 Win7 PE USB 不論USB 2.0 3.0插槽與 USB 2.0 3.0 隨身碟載入PE時皆無法 LOAD rxpe\wimmod 以下的模組
目前只能用光碟或是卡碟機就能完整載入 外置wim 檔案




發表於 2016-11-16 15:44:20 | 顯示全部樓層
fd3233 發表於 2016-11-16 09:48
等會修改完成後上傳
我就不重新開新貼了 此版本只此一版不再做後續更新與精簡

辛苦大大了
好期待大大的完成品,
發表於 2016-11-16 23:20:47 | 顯示全部樓層
雖然還沒下載,先感謝大大無私分享
發表於 2016-11-19 21:03:37 | 顯示全部樓層
已上傳完成  歡迎有能力的人能做後續修改
我覺得如果有win7 64 uefi pe會更好
發表於 2016-11-21 14:42:39 | 顯示全部樓層
感謝大大無私的分享,謝謝。
發表於 2016-11-22 02:07:10 | 顯示全部樓層
fd3233 發表於 2016-11-16 09:48
等會修改完成後上傳
我就不重新開新貼了 此版本只此一版不再做後續更新與精簡

關於:已知問題1.在實體電腦測試  載入顯卡驅動後會有一個常框框不知該如何去除

此狀況發生之可能原因:
此長框框是由PECMD.EXE所產生,而發生之情況為「在執行PECMD DISP指令改變螢幕解析度前,系統執行初始設定之PECMD.EXE還未結束」,就可能會出現此現像!

所以不只「載入顯卡驅動」會發生,直接執行「程式集\設定解析度\…」也可能會發生!

可惜的是「執行初始設定之PECMD.EXE」永遠不會自動結束!

故解決的方法:
1.在會執行「PECMD DISP指令改變螢幕解析度」前,直接開啟「工作管理員\處理程序」,手動結束PECMD.EXE

2.在BOOT.WIM\Windows\System32新增taskkill.exe,修改 7PEDrivers.WIM\INST_DSL.CMD 如下
@echo off
PUSHD %~dp0
TASKKILL /IM PECMD.EXE
PECMD load INST_DSL.INI

EXIT
如此,在「載入顯卡驅動」後,應該就不會有長框框出現!
但要注意:執行「載入顯卡驅動」不可過早,不然可能中斷「PECMD.EXE執行初始化腳本」,或者 taskkill.exe 結束不了正在執行中的PECMD.EXE!

其實較好的解決方式,應為「PECMD.EXE執行初始化腳本」結束,就也從「工作管理員」結束,有人知道這如何修改否!




發表於 2016-11-23 17:29:05 | 顯示全部樓層
wusun 發表於 2016-11-22 02:07
關於:已知問題1.在實體電腦測試  載入顯卡驅動後會有一個常框框不知該如何去除

此狀況發生之可能原因: ...

謝謝 wusun大大 我整合完測試發現在bat 視窗消失前載入驅動還是會有那一條
只要bat 視窗消失後再手動載入就可以了
發表於 2016-11-23 23:29:59 | 顯示全部樓層
fd3233 發表於 2016-11-23 17:29
謝謝 wusun大大 我整合完測試發現在bat 視窗消失前載入驅動還是會有那一條
只要bat 視窗消失後再手動載入 ...

如果 KILL *explorer Explorer 會有幫忙嗎??
您需要登錄後才可以回帖 登錄 | 我要註冊

本版積分規則

小黑屋|手機版|NoName Team 電腦資訊討論區 |網站地圖

GMT+8, 2019-7-20 21:47 , Processed in 0.197440 second(s), 16 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回復 返回頂部 返回列表