請選擇 進入手機版 | 繼續訪問電腦版

NoName Team 電腦資訊討論區

 找回密碼
 我要註冊
搜索
樓主: jerry20530

[分享] [20170315更新]GRUB4DOS+rEFInd 系統安裝、管理 隨身碟(G4D+UEFI)

  [複製鏈接]
發表於 2016-1-19 11:07:13 | 顯示全部樓層
jerry20530 發表於 2016-1-18 21:54
應該沒問題了 開機DEMO BIOS+UEFI 都測過了!!

知道原因囉!因為我下載到你20160117就PO的內容,今天注意到你20160118又PO一次,所以重新下載,就搞定 謝謝!
發表於 2016-1-20 19:13:59 | 顯示全部樓層
本帖最後由 朱正偉 於 2016-1-20 20:39 編輯

很奇怪,總是在win10安裝中,就出現找不到驅動程式,我也有把win10的檔案重新換掉,也一樣,   不管是fat32或ntfs 都一樣情況

我有看到問題情況了,原來是boot.wim 的安裝路經問題,在這邊有看到win10boot修改器,修改後就正常了,
只是有一個奇怪的問題是,我如果把boot.wim  跟install.wim 都放在根目䤸下的sources 這樣是失敗的,
奇怪的是,原始win10 本身的檔案也是放這目䤸 看你那文字說明,自行補檔win10 boot.wim+install.wim  照字面上應也是跟我們說
把boot 跟install 檔放在sources 下面,原始始也是放同樣位置,但就是安裝失敗
最後是用win10 boot修改  它會自動加入3個檔案,進到boot.wim  連帶修改路近,最後才成功,




ps  win7  xp 這2個部份都完全沒問題了,當然附的win7部份(我是從你那邊下載的),有一個小bug 就是,語言列需要再另外去設定過才會出現在右下角    灌了2台都同樣情況
   
 樓主| 發表於 2016-1-20 22:18:35 | 顯示全部樓層
朱正偉 發表於 2016-1-20 19:13
很奇怪,總是在win10安裝中,就出現找不到驅動程式,我也有把win10的檔案重新換掉,也一樣,   不管是fat32 ...

win10 我放10240版本的 boot + install.wim 是沒有問題的 !!

win7 我放的是boot.wim 導引檔 而已..
win7 install.wim 應該是你版本的問題!!
發表於 2016-1-20 23:04:00 | 顯示全部樓層
jerry20530 發表於 2016-1-20 22:18
win10 我放10240版本的 boot + install.wim 是沒有問題的 !!

win7 我放的是boot.wim 導引檔 而已..

我還在納悶為何連 win10 都會找不到驅動
win10 的 boot.wim 不是用訂製版去找訂製目錄下的 install.wim
看來又好像 win10的 boot.wim 去找到 sources 目錄下的 win7 install.wim , 才產生的問題
 樓主| 發表於 2016-1-20 23:52:14 | 顯示全部樓層
2567288 發表於 2016-1-20 23:04
我還在納悶為何連 win10 都會找不到驅動
win10 的 boot.wim 不是用訂製版去找訂製目錄下的 install.wim
...

WIN10 現在應該問題很多!!

前兩版本再測都是用10240 檔案放進去就自己進入安裝模式了
也沒有驅動問題 這樣擺法就跟ISO檔案一樣沒有更動

10586 還要再看看吧 現在大家都是再當白老鼠
測試過現在又一堆問題.......
發表於 2016-1-20 23:59:21 | 顯示全部樓層
jerry20530 發表於 2016-1-20 22:18
win10 我放10240版本的 boot + install.wim 是沒有問題的 !!

win7 我放的是boot.wim 導引檔 而已..

我再來去你那找win10-10240版的install.wim  請問一下,boot.wim 這有附在這裡面嗎?

win7 我在安裝上都沒問題,只要放在win7目綠下面,
你在那裡面放的導引檔路近應是針對sources下的win7目綠
(只要把win7.install.wim 放進去,使用上是沒問題的,看要放什麼版本,自已再修改

win10的板本,我再來上網去找win10原版.iso 跟你那邊下載的10240版看看,
我之前是用10586版,但抓下來只有install.wim     沒有boot.wim
我只好跑去再抓一個多合一的版本   

是不是我要先把10586的install.wim 裡面的boot.wim 取提出來,才會正常 ?   
對了 WIN7你更新後的INSTALL.WIM版本,它在輸入法上面,是直接鎖掉的,
右建也叫不出來,必須要進設定修改,才叫得出來 (這版本是在你那邊抓的,也請你有空時再看一下)



發表於 2016-1-21 00:04:33 | 顯示全部樓層
2567288 發表於 2016-1-20 23:04
我還在納悶為何連 win10 都會找不到驅動
win10 的 boot.wim 不是用訂製版去找訂製目錄下的 install.wim
...

你說的這應該是這樣,我的WIN10 好像跑去找到WIN 7的INSTALL  看來我要再去試看看,把WIN7的INSTALL 先刪掉,看它是否還會找錯,因為我在按SHIST+F10時,是有看到X碟,也是有載入WIM ,只是我沒去看,它是載入那一版的INSTALL.WIM (因為2個檔WIN7跟WIN10的WIM 我都有放進去,我再摸看看)

應有給你猜中,我放在SOURCES目䤸下的BOOT.WIM(WIN10)  這是從多合一版抓下來的BOOT.WIM  

我明天再來去試看看,應也很多玩家跟我一樣的情況,不知怎麼卡住了,我是剛好看到你的10修改器,裡面有說明,路近看自已要怎麼放, 自已再去修改內部設定,改一改就可以用了 q-q   
發表於 2016-1-21 00:09:32 | 顯示全部樓層
jerry20530 發表於 2016-1-20 23:52
WIN10 現在應該問題很多!!

前兩版本再測都是用10240 檔案放進去就自己進入安裝模式了

那大概了解結構 , win10 用原來光碟 iso , win7 用訂製目錄 , 對嗎 ?
如果 win10 是用光碟 iso , 那除了 boot.wim , sources 內除了要有 install.wim 還要有 setup.exe 那個檔案
 樓主| 發表於 2016-1-21 00:28:11 | 顯示全部樓層
2567288 發表於 2016-1-21 00:09
那大概了解結構 , win10 用原來光碟 iso , win7 用訂製目錄 , 對嗎 ?
如果 win10 是用光碟 iso , 那除了  ...

我覺得應該是10586的問題

我預設是放
SOURCES\ 放 setup.exe (win10) 和 7setup.exe (win7)
SOURCES\ win7\boot.wim (改過路徑)

前兩版測試 win10 的 boot.wim + install.wim
10240放進 SOURCES\  就可以安裝系統了

10586 新版的 boot.wim 應該有被亂改過 不然怎麼可能抓不到驅動!!
發表於 2016-1-21 00:36:00 | 顯示全部樓層
朱正偉 發表於 2016-1-21 00:04
你說的這應該是這樣,我的WIN10 好像跑去找到WIN 7的INSTALL  看來我要再去試看看,把WIN7的INSTALL 先刪 ...

安裝的流程
bootmgr --> bcd --> boot.wim --> install.wim
(1) boot.wim 要放在那理都沒關係 , 正常是在 sources 目錄內 , 可以改 bcd 決定位置
(2) install.wim 正常位置在 sources 目錄內 , 標準安裝的話 , sources 目錄內要有 setup.exe 的檔案 (光碟 sources 目錄的 setup.exe , 不是根目錄的 setup.exe)
(3) 如果有兩個系統同時存在 , 兩個系統的 boot.wim , 標準情況都會指向 sources 目錄下的 install.wim
(4) 所以才要改其中一個系統的 boot.wim 讓它指向不同位置的 install.wim (例如 sources\win7\install.wim , 這個目錄就不需要有 setup.exe)
您需要登錄後才可以回帖 登錄 | 我要註冊

本版積分規則

小黑屋|手機版|NoName Team 電腦資訊討論區 |網站地圖

GMT+8, 2019-12-6 23:33 , Processed in 0.338685 second(s), 15 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回復 返回頂部 返回列表